[PATCH] D35496: [codeview] Don't use the type visitor to merge types

Reid Kleckner via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jul 17 10:58:35 PDT 2017


rnk added inline comments.


================
Comment at: llvm/lib/DebugInfo/CodeView/TypeStreamMerger.cpp:282
+  discoverTypeIndices(Type.RecordData, Refs);
+  bool Success = remapIndices(R, Refs);
+  if (isIdRecord(Type.kind())) {
----------------
ruiu wrote:
> What is the meaning of this boolean varaible? Looks like you are not using its value.
It indicates if all type indices were successfully remapped. This gets passed into writeIdRecord / writeRecord, and then we decide to either write the record or map this index to LF_NOTTRANSLATED. It could be renamed AllIndicesMapped, or something.


https://reviews.llvm.org/D35496





More information about the llvm-commits mailing list