[PATCH] D34923: [X86] Add comment string for broadcast loads from the constant pool.

Craig Topper via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sat Jul 1 17:16:30 PDT 2017


craig.topper updated this revision to Diff 105014.
craig.topper added a comment.

Reduce code duplication.

I don't think we have to worry about NaN printing differences because we're going through APFloat's toString in this case which I think is stable.

The place we had NaN variation is when we go through raw_otream::operator<<(double) I think. Though that may have been fixed when an isnan check got added to llvm::write_double back in October. Previously I think we may have fallen into the platform's snprintf implementation.


https://reviews.llvm.org/D34923

Files:
  lib/Target/X86/X86MCInstLower.cpp
  test/CodeGen/X86/avg.ll
  test/CodeGen/X86/avx2-vbroadcast.ll
  test/CodeGen/X86/broadcast-elm-cross-splat-vec.ll
  test/CodeGen/X86/recip-fastmath.ll
  test/CodeGen/X86/recip-fastmath2.ll
  test/CodeGen/X86/vec_shift6.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D34923.105014.patch
Type: text/x-patch
Size: 155314 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20170702/56decbbd/attachment-0001.bin>


More information about the llvm-commits mailing list