[PATCH] D24940: [thinlto] Add cold-callsite import heuristic

Piotr Padlewski via llvm-commits llvm-commits at lists.llvm.org
Tue Sep 27 14:09:01 PDT 2016


Prazek marked an inline comment as done.

================
Comment at: lib/Transforms/IPO/FunctionImport.cpp:301
@@ +300,3 @@
+                   ? ImportColdMultiplier
+                   : 1);
+
----------------
mehdi_amini wrote:
> Too many nested ternary operator IMO (I think more than one hurt readability in general).
I was trying to avoid using not const variable here because the scope is very big. Maybe I shoudl use lambda? 


https://reviews.llvm.org/D24940





More information about the llvm-commits mailing list