[PATCH] D24604: [ELF] - Implemented --sort-section cmd line option and SORT_NONE script command.

George Rimar via llvm-commits llvm-commits at lists.llvm.org
Thu Sep 15 11:09:12 PDT 2016


grimar added inline comments.

================
Comment at: ELF/LinkerScript.cpp:970-972
@@ -969,3 +969,5 @@
     return SortByAlignment;
+  if (skip("SORT_NONE"))
+    return SortDisabled;
   return SortNone;
 }
----------------
ruiu wrote:
> This naming scheme is confusing. SORT_NONE is mapped to SortDisabled, and SortNone doesn't mean SORT_NONE?
Yes, a bit confusing, but according to documentation SORT_NONE is used to _disable_ sorting. A agree that probably better to map it to SortNone, but what is better name for absence of sorting (which is none) ? SortEmpty probably ?


https://reviews.llvm.org/D24604





More information about the llvm-commits mailing list