[PATCH] D24162: [yaml] Add the ability to pass in context at the map level

Chandler Carruth via llvm-commits llvm-commits at lists.llvm.org
Thu Sep 8 10:37:26 PDT 2016


chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.

LGTM with the previous changes and another change below.


================
Comment at: include/llvm/Support/YAMLTraits.h:765
@@ +764,3 @@
+template <typename T, typename Context>
+void do_mapping(IO &io, T &Val, Context &Ctx) {
+  MappingContextTraits<T, Context>::mapping(io, Val, Ctx);
----------------
Is this in some 'internal' or 'detail' namespace that I don't see? If not, I think it probably should be. Seems like too generic of a name.

Also, probably should be doMapping to be consistent with naming conventions (not that this file is terribly consistent with the rest of LLVM's conventions).


https://reviews.llvm.org/D24162





More information about the llvm-commits mailing list