[PATCH] D23965: Add StringRef::keep_front() and StringRef::keep_back()

Adrian McCarthy via llvm-commits llvm-commits at lists.llvm.org
Mon Aug 29 13:22:11 PDT 2016

amccarth added a comment.

I'm torn on the naming debate.  I think `take_back` is awkward, and using `first` and `last` instead of `front` and `back` would make the new names inconsistent with `drop_front` and `drop_back` (and with STL container naming).  I also see that point that `keep` is less precise.

Everything else LGTM.


More information about the llvm-commits mailing list