[PATCH] D20331: [llvm-mc] - Teach llvm-mc to generate compressed debug sections in zlib style.

George Rimar via llvm-commits llvm-commits at lists.llvm.org
Wed May 18 08:03:40 PDT 2016


grimar added inline comments.

================
Comment at: lib/MC/ELFObjectWriter.cpp:576
@@ -575,4 +575,3 @@
   auto &Sec = cast<MCSectionELF>(Sym->getSection());
-  unsigned Flags = Sec.getFlags();
-  if (Flags & ELF::SHF_MERGE) {
+  if (Sec.Flags & ELF::SHF_MERGE) {
     if (C != 0)
----------------
davide wrote:
> You can change that separately, if you really like. It's unrelated, and makes the patch slightly less readable.
Please see my comment below.

================
Comment at: lib/MC/MCSectionELF.cpp:162
@@ -161,5 +161,3 @@
 
-bool MCSectionELF::UseCodeAlign() const {
-  return getFlags() & ELF::SHF_EXECINSTR;
-}
+bool MCSectionELF::UseCodeAlign() const { return Flags & ELF::SHF_EXECINSTR; }
 
----------------
davide wrote:
> Unrelated.
I am sorry but I find this and above change directly related since that changes are connected to what this patch do.
But if you think i need to make Flags variable public at first in separate commit, then I have no problems with that, I just think if this whole patch be approved, then I`ll do 2 commits, but otherwise there is probably no need to perform changes with Flags member.


http://reviews.llvm.org/D20331





More information about the llvm-commits mailing list