[PATCH] D19956: [profile] Remove unnecessary field in raw profile reader

Xinliang David Li via llvm-commits llvm-commits at lists.llvm.org
Thu May 5 12:07:39 PDT 2016


Done.

On Thu, May 5, 2016 at 10:29 AM, Vedant Kumar <vsk at apple.com> wrote:

> vsk accepted this revision.
> vsk added a comment.
> This revision is now accepted and ready to land.
>
> Looks good with a nit.
>
>
> ================
> Comment at: lib/ProfileData/InstrProfReader.cpp:431
> @@ -434,1 +430,3 @@
> +    // At this point, ValueDataStart field points to the next header.
> +    if (std::error_code EC = readNextHeader((const char *)ValueDataStart))
>        return EC;
> ----------------
> I suggest adding something like `getNextHeaderPos()` (which asserts
> `atEnd()`) to RawInstrProfReader for clarity.
>
>
> http://reviews.llvm.org/D19956
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160505/6b4bc43c/attachment.html>


More information about the llvm-commits mailing list