[PATCH] D19956: [profile] Remove unnecessary field in raw profile reader

Vedant Kumar via llvm-commits llvm-commits at lists.llvm.org
Thu May 5 10:29:30 PDT 2016


vsk accepted this revision.
vsk added a comment.
This revision is now accepted and ready to land.

Looks good with a nit.


================
Comment at: lib/ProfileData/InstrProfReader.cpp:431
@@ -434,1 +430,3 @@
+    // At this point, ValueDataStart field points to the next header.
+    if (std::error_code EC = readNextHeader((const char *)ValueDataStart))
       return EC;
----------------
I suggest adding something like `getNextHeaderPos()` (which asserts `atEnd()`) to RawInstrProfReader for clarity.


http://reviews.llvm.org/D19956





More information about the llvm-commits mailing list