[PATCH] D18374: [X86] Use "and $0" and "orl $-1" to store 0 and -1 when optimizing for minsize

Hans Wennborg via llvm-commits llvm-commits at lists.llvm.org
Fri Mar 25 11:16:22 PDT 2016


hans added a comment.

I ran 64-bit bootstrap builds at -Oz of clang with and without my change and measured a binary size reduction of 139264 bytes (0.20 %).


================
Comment at: test/CodeGen/X86/store-zero.ll:1
@@ +1,2 @@
+; RUN: llc -mtriple=i686-unknown-linux-gnu %s -o - | FileCheck %s --check-prefix=CHECK32 --check-prefix=CHECK
+; RUN: llc -mtriple=x86_64-unknown-linux-gnu %s -o - | FileCheck %s --check-prefix=CHECK64 --check-prefix=CHECK
----------------
DavidKreitzer wrote:
> You might want to change the name of the test, since it is testing both 0 and -1.
Good point, renamed.


http://reviews.llvm.org/D18374





More information about the llvm-commits mailing list