[PATCH] D18374: [X86] Use "and $0" and "orl $-1" to store 0 and -1 when optimizing for minsize

David Kreitzer via llvm-commits llvm-commits at lists.llvm.org
Fri Mar 25 06:11:22 PDT 2016

DavidKreitzer added a comment.

Other than a minor suggestion on the test name, LGTM.

Comment at: test/CodeGen/X86/store-zero.ll:1
@@ +1,2 @@
+; RUN: llc -mtriple=i686-unknown-linux-gnu %s -o - | FileCheck %s --check-prefix=CHECK32 --check-prefix=CHECK
+; RUN: llc -mtriple=x86_64-unknown-linux-gnu %s -o - | FileCheck %s --check-prefix=CHECK64 --check-prefix=CHECK
You might want to change the name of the test, since it is testing both 0 and -1.


More information about the llvm-commits mailing list