[PATCH] D17871: [ELF] Generalize ELF symbol type handling

Davide Italiano via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 3 15:27:43 PST 2016


davide created this revision.
davide added reviewers: rafael, grimar, ruiu.
davide added subscribers: emaste, llvm-commits.

SymbolBody constructor and friends take isFunc and isTLS boolean arguments. ELF symbols have already a type so than be easily passed down. This makes code a little bit more readable, I think.
The next patch in this series will remove isTLS.

http://reviews.llvm.org/D17871

Files:
  ELF/Symbols.cpp
  ELF/Symbols.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D17871.49783.patch
Type: text/x-patch
Size: 4339 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20160303/5328a2ba/attachment.bin>


More information about the llvm-commits mailing list