[PATCH] D15762: [Statepoints] Refactor GCRelocateOperands into an intrinsic wrapper. NFC.

Manuel Jacob via llvm-commits llvm-commits at lists.llvm.org
Thu Dec 24 15:54:33 PST 2015

mjacob added a comment.

In http://reviews.llvm.org/D15762#316788, @reames wrote:

> Won't have a chance for an actual review until next week, but wanted to say thanks for the cleanup.  This is a major improvement over the current code.  We probably should do the same for gc.result and gc.statepoint as well at some point.

I'm not sure it makes sense to introduce a wrapper class for gc.result because it would probably only provide a getStatepoint() method. And gc.statepoint would require something different because it can be an invoke as well. I have something in mind which involves making Statepoint a subclass of CallSite.

> Naming wise, I think GCRelocateInst would be more consistent with the other intrinsic wrapper classes.

Yes, that makes sense. I'll change it in the next version.


More information about the llvm-commits mailing list