[PATCH] D15762: [Statepoints] Refactor GCRelocateOperands into an intrinsic wrapper. NFC.
Philip Reames via llvm-commits
llvm-commits at lists.llvm.org
Thu Dec 24 11:09:20 PST 2015
Won't have a chance for an actual review until next week, but wanted to say thanks for the cleanup. This is a major improvement over the current code. We probably should do the same for gc.result and gc.statepoint as well at some point.
Naming wise, I think GCRelocateInst would be more consistent with the other intrinsic wrapper classes.
> On Dec 23, 2015, at 5:41 PM, Manuel Jacob <me at manueljacob.de> wrote:
> mjacob created this revision.
> mjacob added reviewers: reames, sanjoy.
> mjacob added a subscriber: llvm-commits.
> Herald added a subscriber: sanjoy.
> This commit renames GCRelocateOperands to GCRelocate and makes it an
> intrinsic wrapper, similar to e.g. MemCpyInst. Also, all users of
> GCRelocateOperands were changed to use the new intrinsic wrapper instead.
More information about the llvm-commits