[PATCH] D11276: [LoopUnswitch] Code refactoring to separate trivial loop unswitch and non-trivial loop unswitch in processCurrentLoop()
listmail at philipreames.com
Tue Jul 21 13:53:57 PDT 2015
reames added a comment.
> After inlining isTrivialUnswitchCondition() into TryTrivialLoopUnswitch(), isTrivialUnswitchCondition() is basically dead code (no use anywhere). A following patch will be submitted to clean it up.
Please delete it in this commit. It'll generate a warning and some bots treat warnings as errors.
More information about the llvm-commits