[PATCH] LLVM OpenMP CMake Overhaul
chandlerc at google.com
Thu Jun 25 00:39:38 PDT 2015
On Tue, Jun 23, 2015 at 11:37 AM Joerg Sonnenberger <joerg at britannica.bec.de>
> On Tue, Jun 23, 2015 at 04:30:32PM +0000, Jonathan Peyton wrote:
> > 1) Renaming internal variables/macros/functions – everything has
> > libomp_ or LIBOMP_ prefixed to it unless maybe if it is a local
> > variable/parameter inside a function/macro.
> Which reminds me, why do we need or even want something like
> LIBOMP_ARCH and co? It is somewhat annoying that configuration flags
> exists for something that can be perfectly well handled in the code.
> Predefined platform macros exist for a reason.
I very strongly agree. I think moving all of the arch detection to be based
on predefined macros inside the source code would be a big improvement.
However, I'm OK if that comes in a follow-up patch. I'd like to make sure
we make progress here.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits