[PATCH] Make an RAII initializer for COM on Windows
david.majnemer at gmail.com
Fri Apr 24 15:01:36 PDT 2015
In http://reviews.llvm.org/D9267#161495, @zturner wrote:
> In http://reviews.llvm.org/D9267#161494, @majnemer wrote:
> > Might be nice to have 'RAII' in the class name.
> Do we do that for any other types of these classes? For example, there's `llvm_shutdown_obj`, `scoped_ptr`? I don't feel too strongly either way, but if this is a desirable naming convention then we shoudl think about formalizing it.
Sure: NewQueueRAII, TemplateParameterDepthRAII, ContextRAII, FPContractStateRAII, CompoundScopeRAII, CXXThisScopeRAII, ArgumentPackSubstitutionIndexRAII, etc.
More information about the llvm-commits