[llvm] r231082 - DebugInfo: Move new hierarchy into place

Adrian Prantl aprantl at apple.com
Tue Mar 3 14:15:31 PST 2015

Congratulations for landing this!

Sorry for noticing this only _after_ you committed it, but I noticed that DICompositeType’s “Identifier” is too vague to be a useful name for the field. I think calling it UniqueIdentifier or UID for short would be more appropriate, since that is what we are using it for. Similarly DITypeIdentifierMap could become DITypeUIDMap in the process.

-- adrian

More information about the llvm-commits mailing list