[PATCH] [LoopVectorize] Move LoopAccessAnalysis to its own module

hfinkel at anl.gov hfinkel at anl.gov
Sat Jan 31 00:10:42 PST 2015


================
Comment at: include/llvm/Analysis/LoopAccessAnalysis.h:37
@@ +36,3 @@
+/// the user why vectorization did not occur.
+class Report {
+  std::string Message;
----------------
Please rename this -- VectorizationReport perhaps?

================
Comment at: include/llvm/Analysis/LoopAccessAnalysis.h:183
@@ +182,3 @@
+/// \p Message or \p TheLoop's.
+void emitLoopAnalysis(Report &Message, const Function *F, const Loop *L);
+
----------------
These functions are really private to the two implementations; having them in the top-level llvm namespace seems somewhat unfortunate. Any thoughts on some better placement?

================
Comment at: include/llvm/Analysis/LoopAccessAnalysis.h:191
@@ +190,3 @@
+/// \p Ptr.
+const SCEV *replaceSymbolicStrideSCEV(ScalarEvolution *SE,
+                                      ValueToValueMap &PtrToStride,
----------------
We should better document what this does, that PtrToStride is, etc.

http://reviews.llvm.org/D7285

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list