[PATCH] [v5] BPF backend
chandlerc at google.com
Wed Jan 14 00:38:27 PST 2015
(since this came up in a few places)
On Wed, Jan 14, 2015 at 12:13 AM, Alexei Starovoitov <
alexei.starovoitov at gmail.com> wrote:
> > Variable naming in LLVM is still 'ProudCamelCase', so these should be
> Actually that part of coding style is the most confusing:
> $ git grep isVarArg|wc -l
> $ git grep IsVarArg|wc -l
> I see the same in x86, sparc and other backends....
> so I think I picked the right one...
So, first, we use humbleCamelCase for function names and ProudCamelCase for
variable names, so both will get high counts with this kind of grep.
However, our naming conventions are known to not be consistently enforced
across the codebase. We've tried to ask that new code generally follow the
new guidelines where doing so doesn't introduce horrible inconsistency. So
for a class whose base class's virtual methods all use ProudCamelCase
method names, it doesn't make sense to add one new humbleCameCase extra
method. But variables almost never have any consistency concerns such as
this, and for an entirely new backend such concerns should only really
apply to the generic Target interfaces that it is implementing. The rest of
the code should be able to follow the coding standards here IMO.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits