[PATCH] Extract out LPPassManager::cloneLoop

Philip Reames listmail at philipreames.com
Mon Dec 29 14:22:32 PST 2014


================
Comment at: include/llvm/Analysis/LoopPass.h:148
@@ +147,3 @@
+  /// children, mapping the blocks with the specified map.
+  Loop *cloneLoop(Loop *L, Loop *PL, ValueToValueMapTy &VM, LoopInfo *LI);
+
----------------
What does PL stand for?  ParentLoop?  A better name may be called for here.


Also, I'm not sure LPM is the right place for this.  Possibly Transforms/Utils/LoopUtils.h?

================
Comment at: lib/Analysis/LoopPass.cpp:317
@@ +316,3 @@
+                               LoopInfo *LI) {
+  Loop *New = new Loop;
+  insertLoop(New, PL);
----------------
Parens?

http://reviews.llvm.org/D6691

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list