[PATCH] Some code improvements (no functional change)
chandlerc at google.com
Thu Jun 12 08:42:49 PDT 2014
I'm lacking context sadly. =/
On Thu, Jun 12, 2014 at 4:35 PM, Duncan P. N. Exon Smith <
dexonsmith at apple.com> wrote:
> > On 2014 May 29, at 03:41, Artyom Skrobov <Artyom.Skrobov at arm.com> wrote:
> > I'd like to ask your opinion on naming the byte-swapping
> > functions swapByteOrder for the in-place variants, and getBytesSwapped
> > the by-value/return variants; what do you think?
> > In addition to adhering to the lowercase-initial convention advised in
> > Coding Standards, I believe this would also reflect more clearly what the
> > functions are doing, than their current names of SwapValue and
> > SwapByteOrder.
> Generally we don't change the names of old functions that don't match the
> current style guidelines (there's *a lot* of code that predates the style
> guidelines, and this would cause a lot of churn).
> Nevertheless, it'd be nice to have in-place variants. I think something
> like `SwapByteOrderInPlace()` or `ReplaceByteOrder()` might work with the
> naming scheme in the file and minimize code churn.
> Anyone else have an opinion on this? Personally, I prefer Artyom's
> proposal (renaming `SwapByteOrder`).
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits