<div dir="ltr">I'm lacking context sadly. =/</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Thu, Jun 12, 2014 at 4:35 PM, Duncan P. N. Exon Smith <span dir="ltr"><<a href="mailto:dexonsmith@apple.com" target="_blank">dexonsmith@apple.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">> On 2014 May 29, at 03:41, Artyom Skrobov <<a href="mailto:Artyom.Skrobov@arm.com">Artyom.Skrobov@arm.com</a>> wrote:<br>

><br>
> I'd like to ask your opinion on naming the byte-swapping<br>
> functions swapByteOrder for the in-place variants, and getBytesSwapped for<br>
> the by-value/return variants; what do you think?<br>
> In addition to adhering to the lowercase-initial convention advised in the<br>
> Coding Standards, I believe this would also reflect more clearly what the<br>
> functions are doing, than their current names of SwapValue and<br>
> SwapByteOrder.<br>
<br>
Generally we don't change the names of old functions that don't match the<br>
current style guidelines (there's *a lot* of code that predates the style<br>
guidelines, and this would cause a lot of churn).<br>
<br>
Nevertheless, it'd be nice to have in-place variants.  I think something<br>
like `SwapByteOrderInPlace()` or `ReplaceByteOrder()` might work with the<br>
naming scheme in the file and minimize code churn.<br>
<br>
+echristo,rafael,bogner<br>
<br>
Anyone else have an opinion on this?  Personally, I prefer Artyom's<br>
proposal (renaming `SwapByteOrder`).<br>
_______________________________________________<br>
llvm-commits mailing list<br>
<a href="mailto:llvm-commits@cs.uiuc.edu">llvm-commits@cs.uiuc.edu</a><br>
<a href="http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits" target="_blank">http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits</a><br>
</blockquote></div><br></div>