[PATCH] Wrap .subsections_via_symbols directives in #if __APPLE__
jonathan at codesourcery.com
Fri May 9 18:39:46 PDT 2014
Reed, care to bikeshed on a name? I'm drawing a blank.
Another option I considered was to add FILE_LEVEL_DIRECTIVE to the definition of DEFINE_COMPILERRT_PRIVATE_FUNCTION (just like DEFINE_COMPILERRT_FUNCTION has), and delete all of these. I'm not sure if that is correct though as there are a few other builtins that don't have .subsections_via_symbols.
More information about the llvm-commits