[PATCH] Object: Move auxiliary symbol definitions from llvm-readobj

Rafael Avila de Espindola rafael.espindola at gmail.com
Tue Mar 18 19:27:38 PDT 2014


Quiet a bit of lib/object is horribly inconsistent with the rest of llvm. If we don't piggy back the style fixes, they don't get done.

So please, clang format the patch or clang format the entire file.

Sent from my iPhone

> On Mar 18, 2014, at 19:17, David Majnemer <david.majnemer at gmail.com> wrote:
> 
> 
>  I am going to follow the [[ http://llvm.org/docs/CodingStandards.html#golden-rule | golden rule ]] and not run git-clang-format, I'd rather my patch be consistent with the existing code.
> 
> 
> ================
> Comment at: include/llvm/Object/COFF.h:249
> @@ -232,2 +248,3 @@
>   support::ulittle32_t TagIndex;
>   support::ulittle32_t Characteristics;
> +  char                 unused[10];
> ----------------
> Rafael Ávila de Espíndola wrote:
>> Unused would be the correct name according to the LLVM style.
> It would be inconsistent with the other definitions.

Fix the other ones too.

> ================
> Comment at: include/llvm/Object/COFF.h:234
> @@ +233,3 @@
> +  support::ulittle32_t TotalSize;
> +  support::ulittle32_t PointerToLinenumber;
> +  support::ulittle32_t PointerToNextFunction;
> ----------------
> Rafael Ávila de Espíndola wrote:
>> Why rename from PointerToLineNumber?
> Because that is how it is in the spec.
> 
> 
> http://llvm-reviews.chandlerc.com/D3105
> 
> ARCANIST PROJECT
>  llvm




More information about the llvm-commits mailing list