[PATCH] Object: Move auxiliary symbol definitions from llvm-readobj

David Majnemer david.majnemer at gmail.com
Tue Mar 18 19:17:45 PDT 2014

  I am going to follow the [[ http://llvm.org/docs/CodingStandards.html#golden-rule | golden rule ]] and not run git-clang-format, I'd rather my patch be consistent with the existing code.

Comment at: include/llvm/Object/COFF.h:249
@@ -232,2 +248,3 @@
   support::ulittle32_t TagIndex;
   support::ulittle32_t Characteristics;
+  char                 unused[10];
Rafael Ávila de Espíndola wrote:
> Unused would be the correct name according to the LLVM style.
It would be inconsistent with the other definitions.

Comment at: include/llvm/Object/COFF.h:234
@@ +233,3 @@
+  support::ulittle32_t TotalSize;
+  support::ulittle32_t PointerToLinenumber;
+  support::ulittle32_t PointerToNextFunction;
Rafael Ávila de Espíndola wrote:
> Why rename from PointerToLineNumber?
Because that is how it is in the spec.



More information about the llvm-commits mailing list