[llvm-commits] [PATCH] Split AddressSanitizer into two passes (FunctionPass, ModulePass), LLVM part

Kostya Serebryany kcc at google.com
Wed Nov 28 02:43:10 PST 2012


On Wed, Nov 28, 2012 at 2:20 PM, Chandler Carruth <chandlerc at gmail.com>wrote:

>
>   This is also totally fine. =] I have some nits about the name, we can
> sort that out whenever.
>
>
> ================
> Comment at: include/llvm/Transforms/Instrumentation.h:38
> @@ -38,1 +37,3 @@
> +FunctionPass *createAddressSanitizerFunctionPass();
> +ModulePass *createAddressSanitizerModulePass();
>  // Insert ThreadSanitizer (race detection) instrumentation
> ----------------
> I might call this AddressSanitizerGlobalRedZonePass or even
> AddressSanitizerGlobalPass? Essentially, point out the reason why there are
> somethings that necessarily done in a separate (non-function) pass...
>

Committed.
As for the names, I had a vague suspicion that this module pass may do
something else in the future, not just GlobalRedZones

Thanks
--kcc



>
>
> http://llvm-reviews.chandlerc.com/D137
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20121128/9753cb95/attachment.html>


More information about the llvm-commits mailing list