<div style="font-family: arial, helvetica, sans-serif; font-size: 10pt"><br><br><div class="gmail_quote">On Wed, Nov 28, 2012 at 2:20 PM, Chandler Carruth <span dir="ltr"><<a href="mailto:chandlerc@gmail.com" target="_blank">chandlerc@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
  This is also totally fine. =] I have some nits about the name, we can sort that out whenever.<br>
<br>
<br>
================<br>
Comment at: include/llvm/Transforms/Instrumentation.h:38<br>
@@ -38,1 +37,3 @@<br>
<div class="im">+FunctionPass *createAddressSanitizerFunctionPass();<br>
+ModulePass *createAddressSanitizerModulePass();<br>
 // Insert ThreadSanitizer (race detection) instrumentation<br>
</div>----------------<br>
I might call this AddressSanitizerGlobalRedZonePass or even AddressSanitizerGlobalPass? Essentially, point out the reason why there are somethings that necessarily done in a separate (non-function) pass...<br></blockquote>
<div><br></div><div>Committed. </div><div>As for the names, I had a vague suspicion that this module pass may do something else in the future, not just GlobalRedZones</div><div><br></div><div>Thanks </div><div>--kcc </div>
<div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
<br>
<a href="http://llvm-reviews.chandlerc.com/D137" target="_blank">http://llvm-reviews.chandlerc.com/D137</a><br>
</blockquote></div><br></div>