[llvm-commits] [PATCH] PR9493, Fix for DW_AT_location

Robinson, Paul Paul.Robinson at am.sony.com
Tue Jun 19 12:19:53 PDT 2012


Ping, now that people should be recovered from that big conference last week.

--paulr



________________________________
From: llvm-commits-bounces at cs.uiuc.edu [llvm-commits-bounces at cs.uiuc.edu] on behalf of Robinson, Paul [Paul.Robinson at am.sony.com]
Sent: Thursday, June 07, 2012 2:13 PM
To: llvm-commits at cs.uiuc.edu
Subject: [llvm-commits] [PATCH] PR9493, Fix for DW_AT_location


Ping, with improved subject line.

--paulr





My first patch attempt, here goes!



Fix for bug 9493.  On non-Darwin platforms, references from DW_AT_location to the .debug_loc section need to be relocatable.  This patch improves on r127757, which didn't do the right thing for Darwin (and was reverted pretty quickly).



The original bug showed up on ARM, but because of the Darwin/non-Darwin difference I revised the test to target x86_64, where it was easy to try both cases.  Also there isn't an ARM subdirectory under test/DebugInfo and I didn't want to get too ambitious on my first try.  The problem isn't really architecture-specific but it would be easy to create an ARM equivalent for the non-Darwin version of the test, if anybody thought that was useful.



One question, I did not change the name of doesDwarfUseLabelOffsetForRanges() or its underlying data member DwarfUsesLabelOffsetForRanges. These used to apply only to the DW_AT_ranges attribute, but now they apply to DW_AT_location as well. Change the names, or not?  It seemed excessive to add a second function/flag because these DWARF attributes will always want to be handled the same way.  If renaming is better, maybe DwarfUsesRelocationsAcrossSections would be more accurate.

Thanks,

Paul Robinson


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20120619/48a292c2/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: location-reloc.diff
Type: application/octet-stream
Size: 6157 bytes
Desc: location-reloc.diff
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20120619/48a292c2/attachment.obj>


More information about the llvm-commits mailing list