[llvm-commits] [ASan] Replace AsanProcMaps::GetObjectNameAndOffset with a simpler AsanProcMaps::DescribeAddress (issue 5643047)

samsonov at google.com samsonov at google.com
Wed Feb 8 02:51:36 PST 2012


http://codereview.appspot.com/5643047/diff/1/lib/asan/asan_procmaps.h
File lib/asan/asan_procmaps.h (right):

http://codereview.appspot.com/5643047/diff/1/lib/asan/asan_procmaps.h#newcode32
lib/asan/asan_procmaps.h:32: void DescribeAddress(uintptr_t addr, char
out_buffer[], size_t buffer_size);
On 2012/02/08 09:43:33, timurrrr_at_google_com wrote:
> On 2012/02/08 07:11:02, samsonov wrote:
> > Why not GetAddressDescription()?
> Shorter names are better if they mean the same thing, right?

> > We've got two other different DescribeAddress
> > functions already :)
> That's good, no?
Not if they do different things. DescribeAddress we already have acts
like a procedure and prints the description to the output. What you have
here is function that returns the buffer with description. Leaving this
up to you, though.

> One has to remember less names.

http://codereview.appspot.com/5643047/



More information about the llvm-commits mailing list