[llvm-commits] PATCH: Initial patches for changing the semantics of llvm.cttz and llvm.ctlz

Chandler Carruth chandlerc at gmail.com
Thu Dec 1 09:55:52 PST 2011

On Thu, Dec 1, 2011 at 9:52 AM, Chris Lattner <clattner at apple.com> wrote:

> On Dec 1, 2011, at 9:26 AM, Chandler Carruth wrote:
> On Thu, Dec 1, 2011 at 9:08 AM, Chris Lattner <clattner at apple.com> wrote:
>> The only part of this that I find unfortunate is that "llvm.clz" will end
>> up inconsistently named with "llvm.ctpop".
> Is it worth renaming that to llvm.popcount? Other names? I'm happy to do
> more mechanical shuffling while here.
> I kinda liked the old names, but agree we have to change them.  If you're
> going to rename them, we might as well make them longer and more
> descriptive all around.  How about:
> llvm.count.population
> llvm.count.leading.zeros
> llvm.count.trailing.zeros
> or something like that?

I'll wait patiently for the bikeshed to get painted. I have no opinion
other than "clz" being easier to type. ;]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20111201/bc4937f8/attachment.html>

More information about the llvm-commits mailing list