[llvm-commits] PATCH: Initial patches for changing the semantics of llvm.cttz and llvm.ctlz
clattner at apple.com
Thu Dec 1 09:52:16 PST 2011
On Dec 1, 2011, at 9:26 AM, Chandler Carruth wrote:
> On Thu, Dec 1, 2011 at 9:08 AM, Chris Lattner <clattner at apple.com> wrote:
> The only part of this that I find unfortunate is that "llvm.clz" will end up inconsistently named with "llvm.ctpop".
> Is it worth renaming that to llvm.popcount? Other names? I'm happy to do more mechanical shuffling while here.
I kinda liked the old names, but agree we have to change them. If you're going to rename them, we might as well make them longer and more descriptive all around. How about:
or something like that?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits