[llvm-commits] atomics memoperands patch

Mon P Wang monping at apple.com
Tue Jun 24 15:47:18 PDT 2008


Hi,

As I was reviewing code, I noticed that I didn't change the intrinsic  
names.  I'm assuming that we want to change
    llvm.atomic.lcs => llvm.atomic.cmp_swap etc...

and add it to the list to auto-upgrade

-- Mon Ping


On Jun 20, 2008, at 12:26 PM, Evan Cheng wrote:

>
> On Jun 20, 2008, at 9:30 AM, Mon P Wang wrote:
>
>> Hi Evan,
>> On Jun 20, 2008, at 12:11 AM, Evan Cheng wrote:
>>
>>> Thanks Mon Ping. Some comments:
>>>
>>> +           N->getOpcode() == ISD::ATOMIC_LCS  ||
>>> +           N->getOpcode() == ISD::ATOMIC_LAS  ||
>>> +           N->getOpcode() == ISD::ATOMIC_SWAP ||
>>> +           N->getOpcode() == ISD::ATOMIC_LSS  ||
>>> +           N->getOpcode() == ISD::ATOMIC_LOAD_AND  ||
>>> +           N->getOpcode() == ISD::ATOMIC_LOAD_OR   ||
>>> +           N->getOpcode() == ISD::ATOMIC_LOAD_XOR  ||
>>>
>>> Does it make sense to take this opportunity to rename lcs, las, and
>>> lss?
>>>
>>
>> I heard the same comment from Andrew and I think it makes sense.  How
>> about the following
>>  ATOMIC_LCS => ATOMIC_CMP_SWAP
>>  ATOMIC_LAS => ATOMIC_LOAD_ADD
>>  ATOMIC_LSS => ATOMIC_LOAD_SUB
>
> Yes!
>
>>
>>
>> This would make the names more consistent.
>>



More information about the llvm-commits mailing list