[lldb-dev] Does anyone depend on using LLDB with Python 2.6?
Ted Woodward via lldb-dev
lldb-dev at lists.llvm.org
Mon Oct 19 13:33:05 PDT 2015
Ubuntu 10.04 uses 2.6 by default; Ubuntu 12.04 uses 2.7.
We have a bunch of Ubuntu 10 machines here, but anything that runs lldb has 2.7 installed. I’m OK with dropping 2.6 support.
Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, a Linux Foundation Collaborative Project
From: lldb-dev [mailto:lldb-dev-bounces at lists.llvm.org] On Behalf Of Todd Fiala via lldb-dev
Sent: Monday, October 19, 2015 3:04 PM
To: Zachary Turner
Subject: Re: [lldb-dev] Does anyone depend on using LLDB with Python 2.6?
I think the older Ubuntus and the RHEL 7 line both still have a 2.7-based python. I am not aware of any system on the Linux/OS X side where we are seeing Python 2.6 systems anymore.
Can't speak to the BSDs.
My guess would be we don't need to worry about python < 2.7.
On Mon, Oct 19, 2015 at 12:43 PM, Zachary Turner via lldb-dev <lldb-dev at lists.llvm.org <mailto:lldb-dev at lists.llvm.org> > wrote:
AKA: Is Python 2.6 a supported configuration? I found this `argparse_compat.py` file in tests, and it opens with this:
Compatibility module to use the lldb test-suite with Python 2.6.
Warning: This may be buggy. It has not been extensively tested and should only
be used when it is impossible to use a newer Python version.
It is also a special-purpose class for lldb's test-suite.
if sys.version_info >= (2, 7):
raise "This module shouldn't be used when argparse is available (Python >= 2.7)"
print("Using Python 2.6 compatibility layer. Some command line options may not be supported")
lldb-dev mailing list
lldb-dev at lists.llvm.org <mailto:lldb-dev at lists.llvm.org>
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the lldb-dev