[lldb-dev] update: lldb-gdbserver on x86_64 linux

Ed Maste emaste at freebsd.org
Wed Feb 5 12:23:44 PST 2014

On 5 February 2014 12:40, Todd Fiala <tfiala at google.com> wrote:
> > This is the assert (g_swig_init_callback != NULL) in
> ScriptInterpreterPython.cpp?
> Nah - it's an issue with the current default Host process launching on Linux (and maybe FreeBSD?) that doesn't seem to be able to launch a process in a stopped state.  So there's an assert in the posix launch that verifies the launch flag doesn't ask for starting the process in a stopped state.  (Not so helpful for a debugger, eh? ;-) ).  I think this problem will go away when I start bridging over to launching processes correctly soon here.  For the moment you'll see that Linux masks out the launch flag for launch in a debugged state.  Obviously we do this right for local debugging, so I'll be adjusting this code soon.

Interesting.  I ran into a different assert when I first tried it:

$ bin/lldb-gdbserver 1234
Assertion failed: (g_swig_init_callback != NULL), function
InitializePrivate, file
../tools/lldb/source/Interpreter/ScriptInterpreterPython.cpp, line
Abort trap (core dumped)

I just avoided the g_swig_init_callback() call for now to test this
out and it seems to work fine.

$ bin/lldb-gdbserver 1234
using the default platform: host
Listening for a connection on 1234...
Connection established.
  <some debugging>
error: lost connection
lldb-gdbserver exiting...

More information about the lldb-dev mailing list