[Lldb-commits] [PATCH] D47275: 1/3: DWARFDIE split out to DWARFBasicDIE

Greg Clayton via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Wed May 23 13:17:06 PDT 2018


clayborg added a comment.

Marked things that don't belong in DWARFBasicDIE.

Also DWARFBasicDIE doesn't really explain what it actually is. Maybe we should rename this DWARFUnitDIE? DWARFTopDIE? DWARFRootDIE?



================
Comment at: source/Plugins/SymbolFile/DWARF/DWARFBasicDIE.h:49
+
+  bool IsStructOrClass() const;
+
----------------
This will never be true for DWARFBasicDIE. Remove?


================
Comment at: source/Plugins/SymbolFile/DWARF/DWARFBasicDIE.h:115
+
+  const char *GetMangledName() const;
+
----------------
This will never be useful for DWARFBasicDIE since it will represent the first DIE. Remove?


================
Comment at: source/Plugins/SymbolFile/DWARF/DWARFBasicDIE.h:117
+
+  const char *GetPubname() const;
+
----------------
This will never be useful for DWARFBasicDIE since it will represent the first DIE. Remove?


================
Comment at: source/Plugins/SymbolFile/DWARF/DWARFBasicDIE.h:119
+
+  const char *GetQualifiedName(std::string &storage) const;
+
----------------
This will never be useful for DWARFBasicDIE since it will represent the first DIE. Remove?


================
Comment at: source/Plugins/SymbolFile/DWARF/DWARFBasicDIE.h:151-155
+  bool GetDIENamesAndRanges(const char *&name, const char *&mangled,
+                            DWARFRangeList &ranges, int &decl_file,
+                            int &decl_line, int &decl_column, int &call_file,
+                            int &call_line, int &call_column,
+                            lldb_private::DWARFExpression *frame_base) const;
----------------
This will never be useful for DWARFBasicDIE since it will represent the first DIE. Remove?


https://reviews.llvm.org/D47275





More information about the lldb-commits mailing list