[Lldb-commits] [PATCH] D35065: [LLDB][ppc64le] Rename enums in AuxVector

Joerg Sonnenberger via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Thu Jul 6 16:09:28 PDT 2017


joerg added inline comments.


================
Comment at: source/Plugins/DynamicLoader/POSIX-DYLD/AuxVector.cpp:115
   _type:                                                                       \
   name = #_type
   switch (type) {
----------------
krytarowski wrote:
> brunoalr wrote:
> > joerg wrote:
> > > labath wrote:
> > > > If we go about renaming them, then we should change this, as we still want to display the standard name of the entries.
> > > Or name = "AUXV_AT_???" ENTRY_NAME(type) name = #type and then return name + 4;
> > Hmm that looks too "hacky", doesn't it?
> `name + 4` looks prettier to me.
Just using the name directly makes this searchable. The cleanup is an implementation detail, even if it might waste a bit space.


================
Comment at: source/Plugins/DynamicLoader/POSIX-DYLD/AuxVector.h:46
+  /// Added AUXV prefix because some targets already define names such as
+  /// AT_DCACHEBSIZE in system headers
   enum EntryType {
----------------
brunoalr wrote:
> joerg wrote:
> > I think most targets do, but they don't pull the relevant system headers in via namespace pollution.
> Should I change this comment to
> 
> ```
> /// Added AUXV prefix to avoid potential conflicts with system-defined MACROS
> ```
> ?
Yes, please.


https://reviews.llvm.org/D35065





More information about the lldb-commits mailing list