[Lldb-commits] [PATCH] RFC: Proposed change in the disassembly default format in lldb
jmolenda at apple.com
Wed Feb 11 23:10:59 PST 2015
Right, I'm saying that
jmp function+offset (addr) ; comment
is a separate issue that I don't want to touch right now.
Yeah, Greg and I talked about what to put to indicate "this function". Like, literally we were thinking "this" at one point. Greg suggested a function pointer, like "(*)", and then we shortened it to just "*". But after a couple of days looking at output like
0x100032 <*+36>: jump addr ; <*+36>
we were like, you know, the "*" isn't really necessary, we're just used to seeing something there.
I'm not opposed to putting something before the + -- I'm not sure what it should be.
More information about the lldb-commits