[Lldb-commits] [PATCH] RFC: Proposed change in the disassembly default format in lldb
zturner at google.com
Wed Feb 11 23:05:33 PST 2015
Isn't this proposal only for cases of jumping to somewhere else in the same function? Admittedly that's usually the most common type of jump, since it accounts for every control flow instruction.
In any case, I think my suggestion of displaying the operand to the jump instruction as either
jmp function + offset (addr) ; comment
jmp <(this func) + offset> (addr) ; comment
looks the best, but if you think that's outside the scope of this change, then I would at least vote for
jump addr ; <(this func) + offset>
(basically the same as your original proposal, except add some kind of word or string in the middle of <+offset> to make it easier on the eyes.
More information about the lldb-commits