[libc-commits] [PATCH] D75651: [libc] [UnitTest] Add timeout to death tests

Fangrui Song via Phabricator via libc-commits libc-commits at lists.llvm.org
Wed Mar 4 16:20:21 PST 2020


MaskRay added inline comments.


================
Comment at: libc/utils/testutils/ExecuteFunction.h:25
 
-  bool exitedNormally();
-  int getExitCode();
-  int getFatalSignal();
+  static ProcessStatus Error(const char *Error) { return {0, Error}; }
+
----------------
I think for new projects, we don't have to use `VariableName`. We should use the ideal case `variableName`.

https://llvm.org/docs/Proposals/VariableNames.html Everyone agrees that the current `VariableName` convention is broken. People have concerns with existing code base because renaming can clutter up the history. But for a new project, there is simply not meaningful to start with `VariableName`.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75651/new/

https://reviews.llvm.org/D75651





More information about the libc-commits mailing list