[cfe-dev] warning: <tool>: 'linker' input unused when '-fsyntax-only' is present

Argyrios Kyrtzidis akyrtzi at gmail.com
Tue May 22 12:11:16 PDT 2012

On May 22, 2012, at 11:53 AM, Jacob Carlborg wrote:

> I'm writing a tool using libclang. I've used one of Doug Gregor's talks 
> about libclang as a tutorial. One thing is really bugging me and I 
> cannot figure out what I've done wrong. Every time I run the tool I get 
> this output:
> File(FDC34)warning: <tool>: 'linker' input unused when '-fsyntax-only' 
> is present
> The code looks something like this:
> http://pastebin.com/nJ3aWzqh
> I'm invoking the tool with just an input file.

You are passing argv/argc directly as compiler arguments, but these include the name of the executable of your tool in the first string.

> I've tried to search the web but I've been unable to find an answer that 
> provides a working solution.
> -- 
> /Jacob Carlborg
> _______________________________________________
> cfe-dev mailing list
> cfe-dev at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/cfe-dev

More information about the cfe-dev mailing list