[PATCH] D135372: [clang-format] Fix for #58188

Björn Schäpers via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu Oct 6 09:24:25 PDT 2022


HazardyKnusperkeks added a comment.

What is the problem that remains?

Please add a test case.



================
Comment at: clang/lib/Format/UnwrappedLineParser.cpp:1142-1143
+      PPStack.back().Kind == PP_Unreachable &&
+      !(PPStack.size() > 1 &&
+        PPStack[PPStack.size() - 2].Kind == PP_Unreachable);
   if (!PPStack.empty())
----------------
Could you remove the negation? I find negations of compound statements always harder to read.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D135372/new/

https://reviews.llvm.org/D135372



More information about the cfe-commits mailing list