[PATCH] D127745: [clang][dataflow] Rename `getPointeeLoc` to `getReferencePointeeLoc` and `getPointerPointeeLoc` respectively for ReferenceValue and PointerValue.

weiyi via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Tue Jun 14 07:53:03 PDT 2022


wyt created this revision.
Herald added subscribers: tschuett, steakhal, xazax.hun.
Herald added a project: All.
wyt requested review of this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.

We distinguish between getting pointee location for `ReferenceValue` and `PointerValue` as the former must be non-empty but the latter may be empty in the case of a `nullptr`


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D127745

Files:
  clang/include/clang/Analysis/FlowSensitive/Value.h
  clang/lib/Analysis/FlowSensitive/DataflowEnvironment.cpp
  clang/lib/Analysis/FlowSensitive/Models/UncheckedOptionalAccessModel.cpp
  clang/lib/Analysis/FlowSensitive/Transfer.cpp
  clang/unittests/Analysis/FlowSensitive/TransferTest.cpp
  clang/unittests/Analysis/FlowSensitive/TypeErasedDataflowAnalysisTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D127745.436781.patch
Type: text/x-patch
Size: 19227 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20220614/74b4a200/attachment-0001.bin>


More information about the cfe-commits mailing list