[PATCH] D75041: [clang-tidy] Extend 'bugprone-easily-swappable-parameters' with mixability because of implicit conversions

Gabor Marton via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Jun 4 06:59:34 PDT 2021


martong added a comment.

Perhaps all conversion related logic should go into their own implementation file? Seems like it adds up to roughly 1000 lines.



================
Comment at: clang-tools-extra/clang-tidy/bugprone/EasilySwappableParametersCheck.cpp:1171
+                                   "conversion operator.\n");
+        ImplicitSeq <<= ConversionOperatorResult.getValue();
+        WorkType = ImplicitSeq.getTypeAfterUserDefinedConversion();
----------------
I think that these overloaded operators are not elevating the readability, since we are not dealing with mathematical classes.
IMHO, we could simply use `update` or something that is less crypto.



Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75041/new/

https://reviews.llvm.org/D75041



More information about the cfe-commits mailing list