[PATCH] D86671: [clang-tidy] Add new case type to check variables with Hungarian notation

Aaron Ballman via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Fri Aug 28 09:37:08 PDT 2020


aaron.ballman added inline comments.


================
Comment at: clang-tools-extra/clang-tidy/bugprone/ReservedIdentifierCheck.h:44
   llvm::Optional<FailureInfo>
-  GetDeclFailureInfo(const StringRef &TypeName, const NamedDecl *Decl,
+  getDeclFailureInfo(const StringRef &TypeName, const NamedDecl *Decl,
                      const SourceManager &SM) const override;
----------------
dougpuob wrote:
> dougpuob wrote:
> > aaron.ballman wrote:
> > > Given that the other functions in the class use the wrong style of casing, we should probably leave this declaration alone so it doesn't become locally inconsistent.
> > Do you mean create another function with three parameters for it?
> I think I got it. Keep consistent even it is wrong style of casting. 
Yes, exactly!


================
Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:428
 
   case IdentifierNamingCheck::CT_HungarianNotation: {
     const NamedDecl *pNamedDecl = dyn_cast<NamedDecl>(pDecl);
----------------
dougpuob wrote:
> njames93 wrote:
> > aaron.ballman wrote:
> > > I feel like I must be missing something because I don't have this enum in my copy of ToT despite pulling this morning. Is the patch missing some content?
> > I feel like this is an incremental diff based on the first version of this patch rather than a diff from trunk. 
> @aaron.ballman and @njames93, the diff is based on first version not from master(trunk).
> 
> Is it the best way that I should merge with the latest master(trunk) every time before updating the diffs ?
Patches are typically a diff against trunk unless you have a series of related patches that build on top of one another (in which case, Phab has a way to mark related reviews so reviewers can still track the full context of the patch set). So when you create the diff, it should typically be against trunk.


Repository:
  rCTE Clang Tools Extra

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D86671/new/

https://reviews.llvm.org/D86671



More information about the cfe-commits mailing list