[PATCH] D85559: [MSAN] Reintroduce libatomic load/store instrumentation

Evgenii Stepanov via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Thu Aug 13 15:53:48 PDT 2020


eugenis added inline comments.


================
Comment at: llvm/lib/Transforms/Instrumentation/MemorySanitizer.cpp:3513
+    assert(InsPoint);
+    if (!InsPoint) {
+      return;
----------------
guiand wrote:
> TODO: Remove this redudant call
you've already checked it with assert(isa<CallInst>) - which could be changed to isTerminator(), and this could be simplified to NextIRB(CB.getNextNode()).


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D85559/new/

https://reviews.llvm.org/D85559



More information about the cfe-commits mailing list