[PATCH] D82711: [clang-tidy] Fix hicpp-named-paramater

Nathan James via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Sun Jun 28 03:53:29 PDT 2020


njames93 created this revision.
njames93 added reviewers: aaron.ballman, jbcoe.
Herald added subscribers: cfe-commits, xazax.hun.
Herald added a project: clang.

Currently this alias instantiates the readability-identifier-naming check, just swap it out to use the readability-named-paramater check.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D82711

Files:
  clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp


Index: clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp
===================================================================
--- clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp
+++ clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp
@@ -9,6 +9,7 @@
 #include "../ClangTidy.h"
 #include "../ClangTidyModule.h"
 #include "../ClangTidyModuleRegistry.h"
+#include "../bugprone/UndelegatedConstructorCheck.h"
 #include "../bugprone/UseAfterMoveCheck.h"
 #include "../cppcoreguidelines/AvoidGotoCheck.h"
 #include "../cppcoreguidelines/NoMallocCheck.h"
@@ -20,7 +21,6 @@
 #include "../google/ExplicitConstructorCheck.h"
 #include "../misc/NewDeleteOverloadsCheck.h"
 #include "../misc/StaticAssertCheck.h"
-#include "../bugprone/UndelegatedConstructorCheck.h"
 #include "../modernize/AvoidCArraysCheck.h"
 #include "../modernize/DeprecatedHeadersCheck.h"
 #include "../modernize/UseAutoCheck.h"
@@ -34,7 +34,7 @@
 #include "../performance/NoexceptMoveConstructorCheck.h"
 #include "../readability/BracesAroundStatementsCheck.h"
 #include "../readability/FunctionSizeCheck.h"
-#include "../readability/IdentifierNamingCheck.h"
+#include "../readability/NamedParameterCheck.h"
 #include "../readability/UppercaseLiteralSuffixCheck.h"
 #include "ExceptionBaseclassCheck.h"
 #include "MultiwayPathsCoveredCheck.h"
@@ -65,7 +65,7 @@
         "hicpp-explicit-conversions");
     CheckFactories.registerCheck<readability::FunctionSizeCheck>(
         "hicpp-function-size");
-    CheckFactories.registerCheck<readability::IdentifierNamingCheck>(
+    CheckFactories.registerCheck<readability::NamedParameterCheck>(
         "hicpp-named-parameter");
     CheckFactories.registerCheck<bugprone::UseAfterMoveCheck>(
         "hicpp-invalid-access-moved");


-------------- next part --------------
A non-text attachment was scrubbed...
Name: D82711.273915.patch
Type: text/x-patch
Size: 1756 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20200628/109d8e74/attachment-0001.bin>


More information about the cfe-commits mailing list