[PATCH] D71198: [ARM][MVE][Intrinsics] Add VQADDQ, VHADDQ, VRHADDQ, VQSUBQ, VHSUBQ, VQDMULHQ, VQRDMULHQ intrinsics.

Dave Green via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Dec 9 05:17:53 PST 2019


dmgreen added a comment.

Looks nice and clean. I just think we can come up with a better name than adding a _ on the end of it!



================
Comment at: llvm/lib/Target/ARM/ARMInstrMVE.td:1591
 
-class MVE_VQxDMULH<string iname, string suffix, bits<2> size, bit rounding,
+class MVE_VQxDMULH_<string iname, string suffix, bits<2> size, bit rounding,
                   list<dag> pattern=[]>
----------------
Maybe MVE_VQxDMULH_Base or MVE_VQxDMULHInst or something like it


================
Comment at: llvm/lib/Target/ARM/ARMInstrMVE.td:1806
 
-class MVE_VRHADD<string suffix, bit U, bits<2> size, list<dag> pattern=[]>
+class MVE_VRHADD_<string suffix, bit U, bits<2> size, list<dag> pattern=[]>
   : MVE_int<"vrhadd", suffix, size, pattern> {
----------------
Again, better name please.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D71198/new/

https://reviews.llvm.org/D71198





More information about the cfe-commits mailing list