[PATCH] D67695: [clangd] Implement getBeginning for overloaded operators.

Haojian Wu via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Wed Sep 18 00:48:24 PDT 2019


hokein created this revision.
hokein added a reviewer: ilya-biryukov.
Herald added subscribers: usaxena95, kadircet, arphaman, jkorous, MaskRay.
Herald added a project: clang.
hokein marked an inline comment as done.
hokein added inline comments.


================
Comment at: clang-tools-extra/clangd/SourceCode.cpp:256
+
 SourceLocation getBeginningOfIdentifier(const Position &Pos,
                                         const SourceManager &SM,
----------------
the function name doesn't match what it does now, considering a new name for it, `getBeginningOfIdentifierOrOverloadedOperator` seems too verbose, maybe just `getBeginning`?


This will fix some bugs where navigation doesn't work on cases like
`std::cout <^< "hello"`.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D67695

Files:
  clang-tools-extra/clangd/SourceCode.cpp
  clang-tools-extra/clangd/unittests/SourceCodeTests.cpp
  clang-tools-extra/clangd/unittests/XRefsTests.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D67695.220617.patch
Type: text/x-patch
Size: 4665 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/cfe-commits/attachments/20190918/45594e41/attachment.bin>


More information about the cfe-commits mailing list