[PATCH] D66951: [ASTImporter] Add comprehensive tests for ODR violation handling strategies

Gabor Marton via Phabricator via cfe-commits cfe-commits at lists.llvm.org
Mon Sep 16 07:28:46 PDT 2019


martong added inline comments.


================
Comment at: clang/unittests/AST/ASTImporterODRStrategiesTest.cpp:274
+    // There may be a hidden fwd spec decl before a function spec decl.
+    if (auto *PrevF = dyn_cast<FunctionDecl>(ImportedD)) {
+      if (PrevF->getTemplatedKind() ==
----------------
balazske wrote:
> This should be called `ImportedF` instead of `PrevF`?
Ok, renamed to `ImportedF`.
Also removed the superfluous braces.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D66951/new/

https://reviews.llvm.org/D66951





More information about the cfe-commits mailing list